aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-11-05 11:56:14 +1000
committerteor <teor@torproject.org>2019-11-05 12:00:57 +1000
commit9e2a2d38f45c45e455df04c20147bca5ebf078ce (patch)
tree5a5f551bf92419d0e621a4d49ab6a4752022fc2f /Makefile.am
parentc065ad3e3ddbe403702f82b34d3058997562f997 (diff)
downloadtor-9e2a2d38f45c45e455df04c20147bca5ebf078ce.tar.gz
tor-9e2a2d38f45c45e455df04c20147bca5ebf078ce.zip
Makefile: Fix "make autostyle" for out-of-tree builds
Fixes bug 32370; bugfix on 0.4.1.2-alpha.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 9866f87f8c..8b2772577f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -488,19 +488,19 @@ version:
.PHONY: autostyle-ifdefs
autostyle-ifdefs:
- $(PYTHON) scripts/maint/annotate_ifdef_directives.py $(OWNED_TOR_C_FILES)
+ $(PYTHON) $(top_srcdir)/scripts/maint/annotate_ifdef_directives.py $(OWNED_TOR_C_FILES)
.PHONY: autostyle-ifdefs
autostyle-operators:
- $(PERL) scripts/coccinelle/test-operator-cleanup $(OWNED_TOR_C_FILES)
+ $(PERL) $(top_srcdir)/scripts/coccinelle/test-operator-cleanup $(OWNED_TOR_C_FILES)
.PHONY: rectify-includes
rectify-includes:
- $(PYTHON) scripts/maint/rectify_include_paths.py
+ $(PYTHON) $(top_srcdir)/scripts/maint/rectify_include_paths.py
.PHONY: update-copyright
update-copyright:
- $(PERL) scripts/maint/updateCopyright.pl $(OWNED_TOR_C_FILES)
+ $(PERL) $(top_srcdir)/scripts/maint/updateCopyright.pl $(OWNED_TOR_C_FILES)
.PHONY: autostyle
autostyle: update-versions rustfmt autostyle-ifdefs rectify-includes