aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-11-16 21:44:44 +1000
committerNick Mathewson <nickm@torproject.org>2019-12-04 12:15:22 -0500
commit5ce45ac90750ebe9a5d482eef0d9e4a6eb4fbb38 (patch)
tree60fff2f6aa98207336c38635312ac27a6462471a /Makefile.am
parentc7baacf4c0855728077e553a4685577b1344ac82 (diff)
downloadtor-5ce45ac90750ebe9a5d482eef0d9e4a6eb4fbb38.tar.gz
tor-5ce45ac90750ebe9a5d482eef0d9e4a6eb4fbb38.zip
Makefile/git scripts: Add the practracker unit tests
Add a check-practracker-unit-test target, and run it as part of "make check". Add the practracker unit tests to scripts/git/pre-commit.git-hook. Part of 32609.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 38040a4e75..0c3a4fb76d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -253,7 +253,10 @@ test: all
shellcheck:
$(top_srcdir)/scripts/maint/checkShellScripts.sh
-check-local: check-spaces check-changes check-includes check-best-practices shellcheck check-cocci
+check-practracker-unit-test:
+ $(top_srcdir)/scripts/maint/practracker/test_practracker.sh
+
+check-local: check-spaces check-changes check-includes check-practracker-unit-test check-best-practices shellcheck check-cocci
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \