aboutsummaryrefslogtreecommitdiff
path: root/src/rust/tor_util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/rust/tor_util/Cargo.toml')
-rw-r--r--src/rust/tor_util/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/rust/tor_util/Cargo.toml b/src/rust/tor_util/Cargo.toml
index a606a280b2..51e4bd9c5d 100644
--- a/src/rust/tor_util/Cargo.toml
+++ b/src/rust/tor_util/Cargo.toml
@@ -17,3 +17,9 @@ path = "../tor_log"
[dependencies]
libc = "=0.2.39"
+[features]
+# We have to define a feature here because doctests don't get cfg(test),
+# and we need to disable some C dependencies when running the doctests
+# because of the various linker issues. See
+# https://github.com/rust-lang/rust/issues/45599
+test_linking_hack = []