summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/patches/07_log_to_file_by_default.dpatch12
2 files changed, 13 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 9c1e8cd126..1bd4921096 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+tor (0.1.1.17-rc-1) experimental; urgency=low
+
+ * New upstream version.
+ * Forward port patches/07_log_to_file_by_default.
+
+ -- Peter Palfrader <weasel@debian.org> Tue, 28 Mar 2006 09:48:04 +0200
+
tor (0.1.1.16-rc-1) experimental; urgency=low
* New upstream version.
diff --git a/debian/patches/07_log_to_file_by_default.dpatch b/debian/patches/07_log_to_file_by_default.dpatch
index 3ea101780f..da9aaf4324 100755
--- a/debian/patches/07_log_to_file_by_default.dpatch
+++ b/debian/patches/07_log_to_file_by_default.dpatch
@@ -23,15 +23,15 @@ esac
exit 0
@DPATCH@
-diff -urNad tor-0.1.1.5/src/or/config.c /tmp/dpep.YwfNhI/tor-0.1.1.5/src/or/config.c
---- tor-0.1.1.5/src/or/config.c
-+++ /tmp/dpep.YwfNhI/tor-0.1.1.5/src/or/config.c
-@@ -1548,7 +1548,7 @@
+diff -urNad tor-0.1.1.17/src/or/config.c /tmp/dpep.YwfNhI/tor-0.1.1.17/src/or/config.c
+--- tor-0.1.1.17/src/or/config.c
++++ /tmp/dpep.YwfNhI/tor-0.1.1.17/src/or/config.c
+@@ -2079,7 +2079,7 @@
/* Special case on first boot if no Log options are given. */
- if (!options->Logs && !from_setconf) {
+ if (!options->Logs && !from_setconf)
- config_line_append(&options->Logs, "Log", "notice stdout");
+ config_line_append(&options->Logs, "Log", "notice file /var/log/tor/log");
- }
if (options_init_logs(options, 1)<0) /* Validate the log(s) */
+ REJECT("Failed to validate Log options. See logs for details.");