aboutsummaryrefslogtreecommitdiff
path: root/src/rust/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2017-05-02 04:21:42 +0200
committerNick Mathewson <nickm@torproject.org>2017-05-19 08:47:11 -0400
commit70c067102b7d2576fa456d2872bb41abf559dff6 (patch)
tree6feae5f63d84b607fe1e5c196473239ce4919471 /src/rust/Cargo.toml
parentaeba64efad02e596dc3f15832d4bb96184c366a3 (diff)
downloadtor-70c067102b7d2576fa456d2872bb41abf559dff6.tar.gz
tor-70c067102b7d2576fa456d2872bb41abf559dff6.zip
Allow Rust build using locally supplied crates or crates.io
This adds a couple of configure commands to control whether we're requiring all dependencies to be available locally (default) or not (--enable-cargo-online-mode). When building from a tarball, we require the RUST_DEPENDENCIES variable to point to the local repository of crates. This also adds src/ext/rust as a git submodule that contains such a local repository for easy setup.
Diffstat (limited to 'src/rust/Cargo.toml')
-rw-r--r--src/rust/Cargo.toml7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
index 527c536323..fc4377e8b4 100644
--- a/src/rust/Cargo.toml
+++ b/src/rust/Cargo.toml
@@ -5,10 +5,3 @@ members = ["tor_util"]
debug = true
panic = "abort"
-[source.crates-io]
-registry = 'https://github.com/rust-lang/crates.io-index'
-replace-with = 'vendored-sources'
-
-[source.vendored-sources]
-directory = 'vendor'
-