aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2007-12-23 09:46:38 +0000
committerPeter Palfrader <peter@palfrader.org>2007-12-23 09:46:38 +0000
commit03f64638cbc020603efc10a3389552a6c7ca1ec3 (patch)
tree3f16948afe02d503feb803d7179f078419d214c9 /debian
parent2424449947eb06b878dd64bff1cb906f6604989d (diff)
downloadtor-03f64638cbc020603efc10a3389552a6c7ca1ec3.tar.gz
tor-03f64638cbc020603efc10a3389552a6c7ca1ec3.zip
Remove 13_r12907-fix-unit-tests.dpatch (Fix unit tests from HEAD) again - it's
included upstream. svn:r12941
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/13_r12907-fix-unit-tests.dpatch56
3 files changed, 7 insertions, 57 deletions
diff --git a/debian/changelog b/debian/changelog
index eac39c9a56..bc812adcee 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+tor (0.2.0.13-alpha-1+svn) experimental; urgency=low
+
+ * Remove 13_r12907-fix-unit-tests.dpatch (Fix unit tests from HEAD) again -
+ it's included upstream.
+
+ -- Peter Palfrader <weasel@debian.org> Sun, 23 Dec 2007 10:46:18 +0100
+
tor (0.2.0.13-alpha-1) experimental; urgency=low
* New upstream version.
diff --git a/debian/patches/00list b/debian/patches/00list
index 8671d37310..a6d4270cc8 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -3,4 +3,3 @@
06_add_compile_time_defaults.dpatch
07_log_to_file_by_default.dpatch
11_tor_as_root_more_helpful.dpatch
-13_r12907-fix-unit-tests.dpatch
diff --git a/debian/patches/13_r12907-fix-unit-tests.dpatch b/debian/patches/13_r12907-fix-unit-tests.dpatch
deleted file mode 100755
index 67279a33ab..0000000000
--- a/debian/patches/13_r12907-fix-unit-tests.dpatch
+++ /dev/null
@@ -1,56 +0,0 @@
-#! /bin/sh -e
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: No description.
-
-if [ $# -lt 1 ]; then
- echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
- exit 1
-fi
-
-[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
-patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
-
-case "$1" in
- -patch) patch -p1 ${patch_opts} < $0;;
- -unpatch) patch -R -p1 ${patch_opts} < $0;;
- *)
- echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
- exit 1;;
-esac
-
-exit 0
-
-#Author: arma
-#Date: 2007-12-21 05:44:10 -0500 (Fri, 21 Dec 2007)
-#New Revision: 12907
-#
-#Modified:
- #tor/trunk/src/or/test.c
-#Log:
-#the better fix for the unit tests
-#
-#
-#Modified: tor/trunk/src/or/test.c
-#===================================================================
-@DPATCH@
---- tor/src/or/test.c 2007-12-21 10:42:14 UTC (rev 12906)
-+++ tor/src/or/test.c 2007-12-21 10:44:10 UTC (rev 12907)
-@@ -3330,7 +3330,7 @@
- intro->extend_info->addr = crypto_rand_int(65536); /* Does not cover all
- * IP addresses. */
- intro->extend_info->port = crypto_rand_int(65536);
-- intro->intro_key = pk2;
-+ intro->intro_key = crypto_pk_dup_key(pk2);
- smartlist_add(generated->intro_nodes, intro);
- }
- test_assert(rend_encode_v2_descriptors(descs, generated, now,
-#@@ -3374,7 +3374,7 @@
-# rend_encoded_v2_service_descriptor_free(smartlist_get(descs, i));
-# smartlist_free(descs);
-# rend_service_descriptor_free(parsed);
-#-// rend_service_descriptor_free(generated); XXX020
-#+ rend_service_descriptor_free(generated);
-# }
-#
-# static void
-#