aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2005-03-22 22:38:21 +0000
committerPeter Palfrader <peter@palfrader.org>2005-03-22 22:38:21 +0000
commita2ee01984ad5d44b810090ba6da437bd8be1e84d (patch)
treed8a1fa0355dd18f53f6ecc76e39da32c271fdb95 /debian/rules
parent1facdfa8d001ad97d811be2f676caedc9167576c (diff)
downloadtor-a2ee01984ad5d44b810090ba6da437bd8be1e84d.tar.gz
tor-a2ee01984ad5d44b810090ba6da437bd8be1e84d.zip
If "with-dmalloc" is in DEB_BUILD_OPTIONS we build against libdmalloc4.
svn:r3821
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c248290929..b9eee7d20c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -41,6 +41,12 @@ ifneq (,$(findstring notest,$(DEB_BUILD_OPTIONS)))
RUN_TEST = no
endif
+CONF_OPTIONS =
+# build against libdmalloc4 - it better be installed
+ifneq (,$(findstring with-dmalloc,$(DEB_BUILD_OPTIONS)))
+ CONF_OPTIONS += --with-dmalloc
+endif
+
configure: patch-stamp
config.status: configure
dh_testdir
@@ -51,7 +57,8 @@ config.status: configure
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info \
--localstatedir=/var \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ $(CONF_OPTIONS)
build: build-stamp