aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-04-11 00:30:29 +0000
committerNick Mathewson <nickm@torproject.org>2007-04-11 00:30:29 +0000
commit28de06b8e654800bb1221467d6c8cbbf8d19987d (patch)
treea597073932f1ae8407acce3898d103821571723f /configure.in
parent6ba0b0e9f46cedfa83813f1faf63ab4a24456e4d (diff)
downloadtor-28de06b8e654800bb1221467d6c8cbbf8d19987d.tar.gz
tor-28de06b8e654800bb1221467d6c8cbbf8d19987d.zip
r12337@catbus: nickm | 2007-04-10 17:55:26 -0400
Add support for using memory pools to allocate queued cell; pass --disable-cell-pool to configure to disable this. svn:r9939
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f0aebe0ea3..63d76eafc5 100644
--- a/configure.in
+++ b/configure.in
@@ -19,6 +19,14 @@ AC_ARG_ENABLE(debug,
CFLAGS="$CFLAGS -g"
fi])
+AC_ARG_ENABLE(cell-pool,
+ AS_HELP_STRING(--disable-cell-pool, disable pool allocator for cells))
+
+if test x$enable_cell_pool != xno; then
+ AC_DEFINE(ENABLE_CELL_POOL, 1,
+ [Defined if we try to use the pool allocator for queued cells])
+fi
+
AC_ARG_ENABLE(transparent,
AS_HELP_STRING(--disable-transparent, disable transparent proxy support),
[case "${enableval}" in