aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-10-17 16:10:45 +1000
committerteor <teor@torproject.org>2019-10-20 17:52:38 +1000
commitfdf47e0f0b82c10b943ed69717f4f62c0bdff402 (patch)
tree42e51b77127d574f46b4df9ae3532bc78c16b86f /configure.ac
parent2e2e1ed765e8aa42b31d5df92b59850f7db95a00 (diff)
downloadtor-fdf47e0f0b82c10b943ed69717f4f62c0bdff402.tar.gz
tor-fdf47e0f0b82c10b943ed69717f4f62c0bdff402.zip
configure: Make --disable-module-relay imply --disable-module-dirauth
Part of 32123.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dcb8b1e385..9a903fb11e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -260,7 +260,7 @@ m4_define(MODULES, relay dirauth)
dnl Relay module.
AC_ARG_ENABLE([module-relay],
AS_HELP_STRING([--disable-module-relay],
- [Build tor without the Relay modules: tor can not run as a relay, bridge, or authority]))
+ [Build tor without the Relay modules: tor can not run as a relay, bridge, or authority. Implies --disable-module-dirauth]))
AM_CONDITIONAL(BUILD_MODULE_RELAY, [test "x$enable_module_relay" != "xno"])
AM_COND_IF(BUILD_MODULE_RELAY,
AC_DEFINE([HAVE_MODULE_RELAY], [1],
@@ -270,7 +270,7 @@ dnl Directory Authority module.
AC_ARG_ENABLE([module-dirauth],
AS_HELP_STRING([--disable-module-dirauth],
[Build tor without the Directory Authority module: tor can not run as a directory authority or bridge authority]))
-AM_CONDITIONAL(BUILD_MODULE_DIRAUTH,[test "x$enable_module_dirauth" != "xno"])
+AM_CONDITIONAL(BUILD_MODULE_DIRAUTH,[test "x$enable_module_dirauth" != "xno" && test "x$enable_module_relay" != "xno"])
AM_COND_IF(BUILD_MODULE_DIRAUTH,
AC_DEFINE([HAVE_MODULE_DIRAUTH], [1],
[Compile with Directory Authority feature support]))