aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2023-08-23 11:19:52 -0400
committerDavid Goulet <dgoulet@torproject.org>2023-08-23 11:19:52 -0400
commitf332006a53732bb0ec85db340faa3b8cfd8edbf9 (patch)
tree38b1f16639a19e2da35e0a2f4a518aa97079deb2 /configure.ac
parent82a5297d9943549bb3eafd7f2985c3153640f651 (diff)
downloadtor-f332006a53732bb0ec85db340faa3b8cfd8edbf9.tar.gz
tor-f332006a53732bb0ec85db340faa3b8cfd8edbf9.zip
version: Bump to 0.4.9.0-alpha-devtor-0.4.9.0-alpha-dev
Signed-off-by: David Goulet <dgoulet@torproject.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2dcd3d9701..b218a59ce2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ dnl Copyright (c) 2007-2019, The Tor Project, Inc.
dnl See LICENSE for licensing information
AC_PREREQ([2.63])
-AC_INIT([tor],[0.4.8.4])
+AC_INIT([tor],[0.4.9.0-alpha-dev])
AC_CONFIG_SRCDIR([src/app/main/tor_main.c])
AC_CONFIG_MACRO_DIR([m4])
@@ -18,7 +18,7 @@ AC_DEFINE_UNQUOTED([CONFIG_FLAGS], ["$configure_flags"], [Flags passed to config
# version number changes. Tor uses it to make sure that it
# only shuts down for missing "required protocols" when those protocols
# are listed as required by a consensus after this date.
-AC_DEFINE(APPROX_RELEASE_DATE, ["2023-08-23"], # for 0.4.8.4
+AC_DEFINE(APPROX_RELEASE_DATE, ["2023-08-23"], # for 0.4.9.0-alpha-dev
[Approximate date when this software was released. (Updated when the version changes.)])
# "foreign" means we don't follow GNU package layout standards
@@ -2535,7 +2535,7 @@ if test "x$enable_gcc_warnings_advisory" != "xno"; then
], [ TOR_TRY_COMPILE_WITH_CFLAGS(warning_flag, [],
[TOR_WARNING_FLAGS="$TOR_WARNING_FLAGS warning_flag" CFLAGS="$CFLAGS warning_flag"], true)
])
-
+
AX_CHECK_COMPILE_FLAG([-Wextra-semi], [CFLAGS="$CFLAGS -Wextra-semi"], [], [-Werror])
dnl We should re-enable this in some later version. Clang doesn't