aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2020-08-12 14:37:21 -0400
committerNick Mathewson <nickm@torproject.org>2020-08-12 14:37:21 -0400
commite1514420377b2290dfa52fa65374276a66973131 (patch)
tree51955f9b7378e1b736af78226105ac01e342fc26 /configure.ac
parent11f1fe3aca08c19ab07d9380c1bd47678c99abc4 (diff)
parent60c436d14d05dcc5e03058a16373c53ff94469c5 (diff)
downloadtor-e1514420377b2290dfa52fa65374276a66973131.tar.gz
tor-e1514420377b2290dfa52fa65374276a66973131.zip
Merge remote-tracking branch 'tor-gitlab/mr/62'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d580eaaedd..2e1de76606 100644
--- a/configure.ac
+++ b/configure.ac
@@ -866,6 +866,7 @@ dnl Where do you live, libevent? And how do we call you?
if test "$bwin32" = "true"; then
TOR_LIB_WS32=-lws2_32
TOR_LIB_IPHLPAPI=-liphlpapi
+ TOR_LIB_SHLWAPI=-lshlwapi
# Some of the cargo-cults recommend -lwsock32 as well, but I don't
# think it's actually necessary.
TOR_LIB_GDI=-lgdi32
@@ -878,6 +879,7 @@ fi
AC_SUBST(TOR_LIB_WS32)
AC_SUBST(TOR_LIB_GDI)
AC_SUBST(TOR_LIB_IPHLPAPI)
+AC_SUBST(TOR_LIB_SHLWAPI)
AC_SUBST(TOR_LIB_USERENV)
tor_libevent_pkg_redhat="libevent"
@@ -1646,7 +1648,8 @@ AC_CHECK_HEADERS([errno.h \
sys/utime.h \
sys/wait.h \
syslog.h \
- utime.h])
+ utime.h \
+ glob.h])
AC_CHECK_HEADERS(sys/param.h)