aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-01-10 17:21:11 -0500
committerNick Mathewson <nickm@torproject.org>2015-01-10 17:21:11 -0500
commitdc25fb7382b5cb930aaf0cdc842490ff5c11233e (patch)
treeaf29916fa4719100669216bbb9750ef9bd0c3bab /configure.ac
parent740e592790f570c446cbb5e6d4a77f842f75d512 (diff)
downloadtor-dc25fb7382b5cb930aaf0cdc842490ff5c11233e.tar.gz
tor-dc25fb7382b5cb930aaf0cdc842490ff5c11233e.zip
Better workaround for CFLAGS issues from #14072; fixes #14162
When I applied patch fcc78e5f8a3249eadfea31db, I somehow broke stack trace symbols on Linux. I'll leave it to others to figure out why that happens. This should be better. Really. Fixes bug 14162; bug not in any released version of Tor.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2c92a6c409..1fd5960366 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,9 +130,10 @@ fi
if test x$have_systemd = xyes; then
AC_DEFINE(HAVE_SYSTEMD,1,[Have systemd])
- CFLAGS="${CFLAGS} ${SYSTEMD_CFLAGS}"
+ TOR_SYSTEMD_CFLAGS="${SYSTEMD_CFLAGS}"
TOR_SYSTEMD_LIBS="${SYSTEMD_LIBS}"
fi
+AC_SUBST(TOR_SYSTEMD_CFLAGS)
AC_SUBST(TOR_SYSTEMD_LIBS)
if test x$enable_systemd = xyes -a x$have_systemd != xyes ; then
@@ -1543,7 +1544,7 @@ fi
if test "$GCC" = yes; then
# Disable GCC's strict aliasing checks. They are an hours-to-debug
# accident waiting to happen.
- CFLAGS="$CFLAGS -Wall -fno-strict-aliasing -g -O2"
+ CFLAGS="$CFLAGS -Wall -fno-strict-aliasing"
else
# Override optimization level for non-gcc compilers
CFLAGS="$CFLAGS -O"