aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-11-05 12:24:02 -0500
committerNick Mathewson <nickm@torproject.org>2019-11-05 12:24:02 -0500
commitd3e547b2bd93a5e43e90bda144971e243e092a57 (patch)
tree56b879f39c8ac1d46246c2d9bd74f854a5aab42a /configure.ac
parent884056ae57fb1dd80b39c9e503306c02732a551d (diff)
downloadtor-d3e547b2bd93a5e43e90bda144971e243e092a57.tar.gz
tor-d3e547b2bd93a5e43e90bda144971e243e092a57.zip
Re-think our doxygen warnings wrt missing docs and fatalness.
Up till now, we have warned about all missing documentation, which meant that we could never make doxygen warnings fatal. This has led to our doxygen output getting full of errors several times in the past. This commit changes our approach to doxygen warnings: missing documentation warnings are only on when the user asks for them with --enable-missing-doc-warnings. When that option is not present, doxygen respects the --enable-fatal-warnings flag. Closes ticket 32385.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 487361773d..f3c955ad05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,24 @@ AC_ARG_ENABLE(nss,
AC_ARG_ENABLE(pic,
AS_HELP_STRING(--enable-pic, [Build Tor's binaries as position-independent code, suitable to link as a library.]))
+AC_ARG_ENABLE(missing-doc-warnings,
+ AS_HELP_STRING(--enable-missing-doc-warnings, [Tell doxygen to warn about missing documentation.]))
+
+if test "$enable_missing_doc_warnings" = "yes"; then
+ DOXYGEN_FATAL_WARNINGS=NO
+ DOXYGEN_WARN_ON_MISSING=YES
+elif test "$enable_fatal_warnings" = "yes"; then
+ # Fatal warnings from doxygen are nice, but not if we're warning about
+ # missing documentation.
+ DOXYGEN_FATAL_WARNINGS=YES
+ DOXYGEN_WARN_ON_MISSING=NO
+else
+ DOXYGEN_FATAL_WARNINGS=NO
+ DOXYGEN_WARN_ON_MISSING=NO
+fi
+AC_SUBST(DOXYGEN_FATAL_WARNINGS)
+AC_SUBST(DOXYGEN_WARN_ON_MISSING)
+
if test "x$enable_coverage" != "xyes" -a "x$enable_asserts_in_tests" = "xno" ; then
AC_MSG_ERROR([Can't disable assertions outside of coverage build])
fi