aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2021-11-05 12:08:48 -0400
committerNick Mathewson <nickm@torproject.org>2021-11-05 12:36:34 -0400
commitc93114ec9e45f4fb3843012056046eec15b875aa (patch)
tree80cb7a61e78f4d0d37d308534cb1b5646231338b /configure.ac
parent1c77deca4f8e8027eaf130b6454af758e4d9ccc4 (diff)
downloadtor-c93114ec9e45f4fb3843012056046eec15b875aa.tar.gz
tor-c93114ec9e45f4fb3843012056046eec15b875aa.zip
Prefer use of __MINGW_PRINTF/SCANF_FORMAT if available.
Mingw headers sometimes like to define alternative scanf/printf format attributes depending on whether they're using clang, UCRT, MINGW_ANSI_STDIO, or the microsoft version of printf/scanf. This change attempts to use the right one on the given platform. This is an attempt to fix part of #40355.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 366df64609..0d95b19796 100644
--- a/configure.ac
+++ b/configure.ac
@@ -689,6 +689,7 @@ AC_CHECK_FUNCS(
readpassphrase \
rint \
sigaction \
+ snprintf \
socketpair \
statvfs \
strncasecmp \
@@ -706,7 +707,8 @@ AC_CHECK_FUNCS(
uname \
usleep \
vasprintf \
- _vscprintf
+ _vscprintf \
+ vsnprintf
)
# Apple messed up when they added some functions: they