aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2017-02-27 16:25:25 -0500
committerNick Mathewson <nickm@torproject.org>2017-02-27 16:25:25 -0500
commitc0aa7ac5acd7b6f1d261a8a6eb5db2d3571e1f2f (patch)
tree0e2d5196e236390f7f4fb85272ea25a22d73afeb /configure.ac
parent4808540d5c8e132c6ea4db13e25faff6446dc674 (diff)
parentb923c4dc9f011ab8f62e03211407d042dbe9f92a (diff)
downloadtor-c0aa7ac5acd7b6f1d261a8a6eb5db2d3571e1f2f.tar.gz
tor-c0aa7ac5acd7b6f1d261a8a6eb5db2d3571e1f2f.zip
Merge branch 'disable_memory_sentinels_squashed'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 59da60c6c4..05ac9fe846 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,8 @@ AC_ARG_ENABLE(libfuzzer,
AS_HELP_STRING(--enable-libfuzzer, [build extra fuzzers based on 'libfuzzer']))
AC_ARG_ENABLE(oss-fuzz,
AS_HELP_STRING(--enable-oss-fuzz, [build extra fuzzers based on 'oss-fuzz' environment]))
+AC_ARG_ENABLE(memory-sentinels,
+ AS_HELP_STRING(--disable-memory-sentinels, [disable code that tries to prevent some kinds of memory access bugs. For fuzzing only.]))
if test "x$enable_coverage" != "xyes" -a "x$enable_asserts_in_tests" = "xno" ; then
AC_MSG_ERROR([Can't disable assertions outside of coverage build])
@@ -76,6 +78,11 @@ if test "$enable_system_torrc" = "no"; then
[Defined if we're not going to look for a torrc in SYSCONF])
fi
+if test "$enable_memory_sentinels" = "no"; then
+ AC_DEFINE(DISABLE_MEMORY_SENTINELS, 1,
+ [Defined if we're turning off memory safety code to look for bugs])
+fi
+
AM_CONDITIONAL(USE_OPENBSD_MALLOC, test "x$enable_openbsd_malloc" = "xyes")
AC_ARG_ENABLE(asciidoc,