aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMicah Elizabeth Scott <beth@torproject.org>2023-03-08 09:08:23 -0800
committerMicah Elizabeth Scott <beth@torproject.org>2023-05-10 07:38:28 -0700
commit9d1a57397739b869ab102783b858889bcc2e5066 (patch)
treed4ebeb078074afba8e9f311199fef9c57e43314c /configure.ac
parent557eb814863285986039699ce92c6c4f11ee7426 (diff)
downloadtor-9d1a57397739b869ab102783b858889bcc2e5066.tar.gz
tor-9d1a57397739b869ab102783b858889bcc2e5066.zip
configure: Add --enable-gpl option
This change on its own doesn't use the option for anything, but it includes support for configure and a message in 'tor --version' Signed-off-by: Micah Elizabeth Scott <beth@torproject.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index babc65fa8f..a9ea853611 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,19 @@ if test "x$PKG_CONFIG_PATH" = "x" && test "x$prefix" != "xNONE" && test "$host"
AC_MSG_NOTICE([set PKG_CONFIG_PATH=$PKG_CONFIG_PATH to support cross-compiling])
fi
+# License options
+
+AC_ARG_ENABLE(gpl,
+ AS_HELP_STRING(--enable-gpl, [allow the inclusion of GPL-licensed code, building a version of tor and libtor covered by the GPL rather than its usual 3-clause BSD license]))
+license_option=BSD
+AS_IF([test "x$enable_gpl" = xyes],
+ [
+ AC_DEFINE(ENABLE_GPL, 1, [Defined if tor is building in GPL-licensed mode.])
+ license_option=GPL
+ ])
+
+# Optional features
+
AC_ARG_ENABLE(openbsd-malloc,
AS_HELP_STRING(--enable-openbsd-malloc, [use malloc code from OpenBSD. Linux only. Deprecated: see --with-malloc]))
AC_ARG_ENABLE(static-openssl,
@@ -2651,6 +2664,7 @@ PPRINT_SUBTITLE([Build Features])
PPRINT_PROP_STRING([Compiler], [$CC])
PPRINT_PROP_STRING([Host OS], [$host_os])
+PPRINT_PROP_STRING([License Option], [$license_option])
AS_ECHO
test "x$enable_fatal_warnings" = "xyes" && value=1 || value=0