aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Færøy <ahf@torproject.org>2021-11-08 14:16:18 +0000
committerAlexander Færøy <ahf@torproject.org>2021-11-08 14:16:18 +0000
commit882fd1f0d45656e0535e70b5e115281b39ac6307 (patch)
treebee76c5ec9010bbf5ce03a96e4d7dd254fb43a4c /configure.ac
parenta7fe37f1fa7821d0bdbeabe480df8aba7dc1fded (diff)
parent4a24673436b2f8cf7a6bbbb353f97f1ae403e411 (diff)
downloadtor-882fd1f0d45656e0535e70b5e115281b39ac6307.tar.gz
tor-882fd1f0d45656e0535e70b5e115281b39ac6307.zip
Merge branch 'maint-0.3.5' into maint-0.4.5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 52ec019d01..0e714e66c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1103,7 +1103,7 @@ dnl warnings.
AC_MSG_CHECKING([for OpenSSL >= 3.0.0])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <openssl/opensslv.h>
-#if !defined(LIBRESSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER <= 0x30000000L
+#if !defined(LIBRESSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x30000000L
#error "you_have_version_3"
#endif
]], [[]])],
@@ -1121,6 +1121,18 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
[ AC_MSG_RESULT([no]) ],
[ AC_MSG_ERROR([OpenSSL is too old. We require 1.0.1 or later. You can specify a path to a newer one with --with-openssl-dir.]) ])
+AC_MSG_CHECKING([whether LibreSSL TLS 1.3 APIs are busted])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include <openssl/opensslv.h>
+#if defined(LIBRESSL_VERSION_NUMBER) && \
+ LIBRESSL_VERSION_NUMBER >= 0x3020100fL && \
+ LIBRESSL_VERSION_NUMBER < 0x3040100fL
+#error "oh no"
+#endif
+ ]], [[]])],
+ [ AC_MSG_RESULT([no]) ],
+ [ AC_MSG_ERROR([This version of LibreSSL won't work with Tor. Please upgrade to LibreSSL 3.4.1 or later. (Or downgrade to 3.2.0 if you really must.)]) ])
+
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <openssl/opensslv.h>
#include <openssl/evp.h>