aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2017-09-20 15:54:36 -0400
committerNick Mathewson <nickm@torproject.org>2017-09-20 16:07:19 -0400
commit564ff506ea34ef44422470ed4dc2856e0c234c87 (patch)
treeb1f8d44327cdeed956085117699289e436db0ca4 /configure.ac
parent2c93be80d9ad0712b5716c85e32f7a5184f3b1d2 (diff)
downloadtor-564ff506ea34ef44422470ed4dc2856e0c234c87.tar.gz
tor-564ff506ea34ef44422470ed4dc2856e0c234c87.zip
When detecting OpenSSL, look for 1.0.1, and in homebrew location
Previously we would detect the system openssl on OSX, and then fail to use it, since we required Open 1.0.1 or later. That's silly! Instead of looking for RAND_add(), look for TLSv1_1_method(): it was introduced in 1.0.1, and is also present in LibreSSL. Also, add the hombebrew path to our search path here. Fixes bug 23602; bugfix on 0.2.7.2-alpha.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 76140cbd19..eaa0cd2be6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -612,11 +612,12 @@ AC_ARG_WITH(ssl-dir,
fi
])
+AC_MSG_NOTICE([Now, we'll look for OpenSSL >= 1.0.1])
TOR_SEARCH_LIBRARY(openssl, $tryssldir, [-lssl -lcrypto $TOR_LIB_GDI],
- [#include <openssl/rand.h>],
- [void RAND_add(const void *buf, int num, double entropy);],
- [RAND_add((void*)0,0,0);], [],
- [/usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local /usr/athena /opt/openssl])
+ [#include <openssl/ssl.h>],
+ [struct ssl_method_st; const struct ssl_method_st *TLSv1_1_method(void);],
+ [TLSv1_1_method();], [],
+ [/usr/local/opt/openssl /usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local /usr/athena /opt/openssl])
dnl XXXX check for OPENSSL_VERSION_NUMBER == SSLeay()