aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrl1987 <rl1987@sdf.lonestar.org>2020-03-13 20:24:54 +0200
committerteor <teor@torproject.org>2020-03-17 21:06:15 +1000
commit5591f424753c1f732e4c9d58b31070b878f18484 (patch)
tree5ed481d24aea865312968074669ad783e3110b64 /configure.ac
parent437da7fb3a1a8834a2cc939119f71da15d5bea64 (diff)
downloadtor-5591f424753c1f732e4c9d58b31070b878f18484.tar.gz
tor-5591f424753c1f732e4c9d58b31070b878f18484.zip
Add --enable-all-bugs-are-fatal option to configure
This option enables the ALL_BUGS_ARE_FATAL macro. And use --enable-all-bugs-are-fatal in the Travis configuration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa511a3911..9d3bef999f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,6 +228,13 @@ if test "x$enable_expensive_hardening" = "xyes" || test "x$enable_fragile_harden
AC_DEFINE(DEBUG_SMARTLIST, 1, [Enable smartlist debugging])
fi
+AC_ARG_ENABLE(all-bugs-are-fatal,
+ AS_HELP_STRING(--enable-all-bugs-are-fatal, [force all soft asserts in Tor codebase (tor_assert_nonfatal(), BUG(), etc.) to act as hard asserts (tor_assert() and equivalents); makes Tor fragile; only recommended for dev builds]))
+
+if test "x$enable_all_bugs_are_fatal" = "xyes"; then
+ AC_DEFINE(ALL_BUGS_ARE_FATAL, 1, [All assert failures are fatal])
+fi
+
dnl Linker hardening options
dnl Currently these options are ELF specific - you can't use this with MacOSX
AC_ARG_ENABLE(linker-hardening,