aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-09-24 20:43:48 -0400
committerNick Mathewson <nickm@torproject.org>2015-01-14 11:01:19 -0500
commit51bc0e7f3d612b099382500b434d31f179eaa8a8 (patch)
tree5efe2a9786609a33876e35411bbf7f0df9b37f76 /configure.ac
parentc7eebe237ddf0555a99b2ef10fd95def2a4bbbd4 (diff)
downloadtor-51bc0e7f3d612b099382500b434d31f179eaa8a8.tar.gz
tor-51bc0e7f3d612b099382500b434d31f179eaa8a8.zip
Isolate the "socketpair or a pipe" logic for alerting main thread
This way we can use the linux eventfd extension where available. Using EVFILT_USER on the BSDs will be a teeny bit trickier, and will require libevent hacking.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65b3ff245c..69a266a717 100644
--- a/configure.ac
+++ b/configure.ac
@@ -407,6 +407,7 @@ AC_CHECK_FUNCS(
backtrace \
backtrace_symbols_fd \
clock_gettime \
+ eventfd \
flock \
ftime \
getaddrinfo \
@@ -421,6 +422,8 @@ AC_CHECK_FUNCS(
localtime_r \
lround \
memmem \
+ pipe \
+ pipe2 \
prctl \
rint \
sigaction \
@@ -962,6 +965,7 @@ AC_CHECK_HEADERS(
netinet/in6.h \
pwd.h \
stdint.h \
+ sys/eventfd.h \
sys/file.h \
sys/ioctl.h \
sys/limits.h \