aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2021-09-23 09:21:13 -0400
committerSimon South <simon@simonsouth.net>2021-09-28 11:06:52 -0400
commit3bc3a108955c7b25a13808a2cfefcc77d2364cf4 (patch)
treeda854d007520814920c0412f5bffbb9eca7e26f5 /configure.ac
parentfbf2e7e9218b8e0ffabcd59fab2322d7c2c7178c (diff)
downloadtor-3bc3a108955c7b25a13808a2cfefcc77d2364cf4.tar.gz
tor-3bc3a108955c7b25a13808a2cfefcc77d2364cf4.zip
configure.ac: Define ENABLE_COVERAGE macro
Allow conditional compilation based on whether the "--enable-coverage" configure option was specified.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b4617a4003..f010c547b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,11 @@ AM_CONDITIONAL(USE_RUST, test "x$enable_rust" = "xyes")
AM_CONDITIONAL(USE_NSS, test "x$enable_nss" = "xyes")
AM_CONDITIONAL(USE_OPENSSL, test "x$enable_nss" != "xyes")
+if test "x$enable_coverage" = "xyes"; then
+ AC_DEFINE(ENABLE_COVERAGE, 1,
+ [Defined if coverage support is enabled for the unit tests])
+fi
+
if test "x$enable_nss" = "xyes"; then
AC_DEFINE(ENABLE_NSS, 1,
[Defined if we're building with NSS.])