aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2021-09-22 14:42:45 -0400
committerSimon South <simon@simonsouth.net>2021-09-27 12:13:47 -0400
commit352677556e14480753f75e8abe1f584f1580f1b2 (patch)
treeaf3a05b850515216dbaa15e23b3e6bfac8a0995e /configure.ac
parentecb91e75e4770fa76c64c7b1932985de024d693e (diff)
downloadtor-352677556e14480753f75e8abe1f584f1580f1b2.tar.gz
tor-352677556e14480753f75e8abe1f584f1580f1b2.zip
configure.ac: Define ENABLE_FRAGILE_HARDENING macro
Allow conditional compilation based on whether the "--enable-fragile-hardening" configure option was specified.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 23ba4b0d2d..b4617a4003 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,6 +233,7 @@ AC_ARG_ENABLE(fragile-hardening,
AS_HELP_STRING(--enable-fragile-hardening, [enable more fragile and expensive compiler hardening; makes Tor slower]))
if test "x$enable_expensive_hardening" = "xyes" || test "x$enable_fragile_hardening" = "xyes"; then
fragile_hardening="yes"
+ AC_DEFINE(ENABLE_FRAGILE_HARDENING, 1, [Defined if we're building with additional, fragile and expensive compiler hardening])
AC_DEFINE(DEBUG_SMARTLIST, 1, [Enable smartlist debugging])
fi