aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Pinto <danielpinto52@gmail.com>2020-06-03 22:09:42 +0100
committerDaniel Pinto <danielpinto52@gmail.com>2020-07-15 22:01:08 +0100
commit34fa2c4d0d8117b75c5c52a7c825486eb0284ae0 (patch)
tree572264180e98fe572d16a42d44f3b60fd4e9f52a /configure.ac
parenta7226ca06e20356abb057c29416a9ad969c8d29d (diff)
downloadtor-34fa2c4d0d8117b75c5c52a7c825486eb0284ae0.tar.gz
tor-34fa2c4d0d8117b75c5c52a7c825486eb0284ae0.zip
Add support for patterns on %include #25140
Also adds generic tor_glob function to expand globs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3076f2f1ff..b53df59148 100644
--- a/configure.ac
+++ b/configure.ac
@@ -866,6 +866,7 @@ dnl Where do you live, libevent? And how do we call you?
if test "$bwin32" = "true"; then
TOR_LIB_WS32=-lws2_32
TOR_LIB_IPHLPAPI=-liphlpapi
+ TOR_LIB_SHLWAPI=-lshlwapi
# Some of the cargo-cults recommend -lwsock32 as well, but I don't
# think it's actually necessary.
TOR_LIB_GDI=-lgdi32
@@ -878,6 +879,7 @@ fi
AC_SUBST(TOR_LIB_WS32)
AC_SUBST(TOR_LIB_GDI)
AC_SUBST(TOR_LIB_IPHLPAPI)
+AC_SUBST(TOR_LIB_SHLWAPI)
AC_SUBST(TOR_LIB_USERENV)
tor_libevent_pkg_redhat="libevent"
@@ -1646,7 +1648,8 @@ AC_CHECK_HEADERS([errno.h \
sys/utime.h \
sys/wait.h \
syslog.h \
- utime.h])
+ utime.h \
+ glob.h])
AC_CHECK_HEADERS(sys/param.h)