aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-12-23 11:02:04 -0500
committerNick Mathewson <nickm@torproject.org>2016-12-23 11:02:04 -0500
commit1fbb66fa77939ffcfc57056ce212e7ecf98ad7af (patch)
tree371194784e1d11e73a4702768f6e16f167dbb499 /configure.ac
parent0a0e513d42581a8ae110307d1bac58ddb89a8df1 (diff)
parentc27ae62adefb9fcdf468eef43e8a33ae3657a6bf (diff)
downloadtor-1fbb66fa77939ffcfc57056ce212e7ecf98ad7af.tar.gz
tor-1fbb66fa77939ffcfc57056ce212e7ecf98ad7af.zip
Merge branch 'maint-0.2.9'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1689cbee7b..e3ea8f5bd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -507,12 +507,13 @@ TOR_SEARCH_LIBRARY(libevent, $trylibeventdir, [-levent $STATIC_LIBEVENT_FLAGS $T
#ifdef _WIN32
#include <winsock2.h>
#endif
-void *event_init(void);],
+struct event_base;
+struct event_base *event_base_new(void);],
[
#ifdef _WIN32
{WSADATA d; WSAStartup(0x101,&d); }
#endif
-event_init();
+event_base_new();
], [--with-libevent-dir], [/opt/libevent])
dnl Determine the incantation needed to link libevent.