aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy <andy@blockbreakers.org>2022-10-13 16:35:19 -0600
committerAndy <andy@blockbreakers.org>2022-11-01 15:32:43 -0600
commit1bb386a759a67c95d12fa1165332d1e1afbb5f1c (patch)
treed09fe0583def23b06646436f2ea8bb700a219e34 /configure.ac
parent5afaf1856f01a0eeb894d259af84ddc1574a5d3b (diff)
downloadtor-1bb386a759a67c95d12fa1165332d1e1afbb5f1c.tar.gz
tor-1bb386a759a67c95d12fa1165332d1e1afbb5f1c.zip
added check for compiler support of Wextra-semi
update AX_CHECK_COMPILE_FLAG function call
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6ab7903010..74ea8050ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2357,7 +2357,6 @@ if test "x$enable_gcc_warnings_advisory" != "xno"; then
-Wexplicit-ownership-type
-Wextern-initializer
-Wextra
- -Wextra-semi
-Wextra-tokens
-Wflexible-array-extensions
-Wfloat-conversion
@@ -2504,6 +2503,8 @@ if test "x$enable_gcc_warnings_advisory" != "xno"; then
], [ TOR_TRY_COMPILE_WITH_CFLAGS(warning_flag, [],
[TOR_WARNING_FLAGS="$TOR_WARNING_FLAGS warning_flag" CFLAGS="$CFLAGS warning_flag"], true)
])
+
+ AX_CHECK_COMPILE_FLAG([-Wextra-semi], [CFLAGS="$CFLAGS -Wextra-semi"], [], [-Werror])
dnl We should re-enable this in some later version. Clang doesn't
dnl mind, but it causes trouble with GCC.