aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2020-03-17 21:08:45 +1000
committerteor <teor@torproject.org>2020-03-17 21:08:45 +1000
commit0fa1d8ef92a2911fcf660bc57637d525988d63b6 (patch)
tree56d01e9b46dccdca918c0df20f8e7a1b6a56729a /configure.ac
parent9c73f5adc4e766b6c5875deeb365f4e40a6caebc (diff)
parent5675cbd4c756283419fb0ed3b2d524b2b3cb101b (diff)
downloadtor-0fa1d8ef92a2911fcf660bc57637d525988d63b6.tar.gz
tor-0fa1d8ef92a2911fcf660bc57637d525988d63b6.zip
Merge branch 'pr1777_squashed'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ded3a0ac5..87e7ea0cad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,6 +228,13 @@ if test "x$enable_expensive_hardening" = "xyes" || test "x$enable_fragile_harden
AC_DEFINE(DEBUG_SMARTLIST, 1, [Enable smartlist debugging])
fi
+AC_ARG_ENABLE(all-bugs-are-fatal,
+ AS_HELP_STRING(--enable-all-bugs-are-fatal, [force all soft asserts in Tor codebase (tor_assert_nonfatal(), BUG(), etc.) to act as hard asserts (tor_assert() and equivalents); makes Tor fragile; only recommended for dev builds]))
+
+if test "x$enable_all_bugs_are_fatal" = "xyes"; then
+ AC_DEFINE(ALL_BUGS_ARE_FATAL, 1, [All assert failures are fatal])
+fi
+
dnl Linker hardening options
dnl Currently these options are ELF specific - you can't use this with MacOSX
AC_ARG_ENABLE(linker-hardening,