aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2021-10-28 16:29:22 -0400
committerDavid Goulet <dgoulet@torproject.org>2021-10-28 16:29:45 -0400
commitfbc6d2d76a6b3dd55ade29b717b1f20a86a4d4d3 (patch)
treeea570b79b91c31821d8a80c908dc9388cec0a373 /Makefile.am
parentc845f2e4b24753974fe5615290a083291590687f (diff)
downloadtor-fbc6d2d76a6b3dd55ade29b717b1f20a86a4d4d3.tar.gz
tor-fbc6d2d76a6b3dd55ade29b717b1f20a86a4d4d3.zip
makefile: Add a reproducible dist make job
Signed-off-by: David Goulet <dgoulet@torproject.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index df3f88d6f5..b059496688 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -680,3 +680,7 @@ lsp:
else \
echo "No bear command found. On debian, apt install bear"; \
fi
+
+# Reproducible tarball. We change the tar options for this.
+dist-reprod:
+ $(MAKE) dist am__tar="$${TAR-tar} --format=gnu --owner=root --group=root --sort=name --mtime=\"`git show --no-patch --format='%ci'`\" -chof - $(distdir)"