aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2020-10-19 15:15:47 -0400
committerDavid Goulet <dgoulet@torproject.org>2020-10-27 10:43:42 -0400
commitec731290a5a790093961f0fdb06cf69000194adf (patch)
treeda6a2351d3bb17071c64f493edfa292e4257c7ec /Makefile.am
parentbd582583f610d568bb61d1a108d1ff4f38ef08b5 (diff)
downloadtor-ec731290a5a790093961f0fdb06cf69000194adf.tar.gz
tor-ec731290a5a790093961f0fdb06cf69000194adf.zip
lib: New metrics library
Used to provide an interface to create metrics store and update the entries. Related to #40063 Signed-off-by: David Goulet <dgoulet@torproject.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 50b002139e..96658230f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,7 +73,8 @@ TOR_UTIL_LIBS = \
src/lib/libtor-version.a \
src/lib/libtor-llharden.a \
src/lib/libtor-intmath.a \
- src/lib/libtor-ctime.a
+ src/lib/libtor-ctime.a \
+ src/lib/libtor-metrics.a
# Variants of the above for linking the testing variant of tor (for coverage
# and tests)
@@ -108,7 +109,8 @@ TOR_UTIL_TESTING_LIBS = \
src/lib/libtor-version-testing.a \
src/lib/libtor-llharden-testing.a \
src/lib/libtor-intmath.a \
- src/lib/libtor-ctime-testing.a
+ src/lib/libtor-ctime-testing.a \
+ src/lib/libtor-metrics-testing.a
endif
# Internal crypto libraries used in Tor