aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2020-02-17 14:50:24 +1000
committerteor <teor@torproject.org>2020-02-17 14:55:05 +1000
commitda280a430906349fd697860fbe326de86eccd36d (patch)
treeb65b293b2b41d220b5f89fa56b25f2c448299aa5 /Makefile.am
parent85eb170923bdc7b42db971fd35e59281333931a2 (diff)
downloadtor-da280a430906349fd697860fbe326de86eccd36d.tar.gz
tor-da280a430906349fd697860fbe326de86eccd36d.zip
Makefile: Add an IPv6 mixed chutney network
This network is used in make test-network-all and test-network-ipv6. Closes 33334.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e57570a06..0284885654 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -317,7 +317,8 @@ test-network-all:
@$(MAKE) test-network-run \
ipv4_flavors="$(TEST_CHUTNEY_FLAVORS)" \
mixed_flavors="$(TEST_CHUTNEY_FLAVORS_MIXED)" \
- ipv6_flavors="$(TEST_CHUTNEY_FLAVORS_IPV6)"
+ ipv6_flavors="$(TEST_CHUTNEY_FLAVORS_IPV6)" \
+ ipv6_mixed_flavors="$(TEST_CHUTNEY_FLAVORS_IPV6_MIXED)"
@$(MAKE) test-network-results
# Run IPv4 and mixed tests using automake's test-driver
@@ -338,7 +339,8 @@ test-network-ipv6:
@$(MAKE) test-network-mkdir
@$(MAKE) test-network-clean
@$(MAKE) test-network-run \
- ipv6_flavors="$(TEST_CHUTNEY_FLAVORS_IPV6)"
+ ipv6_flavors="$(TEST_CHUTNEY_FLAVORS_IPV6)" \
+ ipv6_mixed_flavors="$(TEST_CHUTNEY_FLAVORS_IPV6_MIXED)"
@$(MAKE) test-network-results
# Make the test network log directory, if it does not exist