aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-08-30 22:25:14 +1000
committerteor <teor@torproject.org>2019-09-05 11:15:22 +1000
commitd14573a62371fd6d21ed801bc89e2f3ebdb98b2b (patch)
tree6d5ed219fd2b502e1ca966a0a9877cd48ff9ef77 /Makefile.am
parent34f3fcef408a91275561e86afc3bd1d2da3b0375 (diff)
downloadtor-d14573a62371fd6d21ed801bc89e2f3ebdb98b2b.tar.gz
tor-d14573a62371fd6d21ed801bc89e2f3ebdb98b2b.zip
Makefile: Explicitly list the subdirectories that contain scripts
Part of 30967.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5cc4305cb6..25c6562c10 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -239,9 +239,10 @@ test: all
$(top_builddir)/src/test/test
shellcheck:
- # Only use shellcheck if it is present
+ # Only use shellcheck if shellcheck is installed
+ # Check the directories that contain scripts that we can fix
if command -v shellcheck; then \
- find "$(top_srcdir)" -name "*.sh" -not -path "$(top_srcdir)/src/ext/*" -not -path "$(top_srcdir)/src/rust/registry/*" -exec shellcheck {} +; \
+ find "$(top_srcdir)" -name "*.sh" -path "$(top_srcdir)/contrib/*" -path "$(top_srcdir)/doc/*" -path "$(top_srcdir)/scripts/*" -path "$(top_srcdir)/src/*" -not -path "$(top_srcdir)/src/ext/*" -not -path "$(top_srcdir)/src/rust/registry/*" -exec shellcheck {} +; \
if [ -d "$(top_srcdir)/scripts/test" ]; then \
shellcheck $(top_srcdir)/scripts/test/cov-diff $(top_srcdir)/scripts/test/coverage; \
fi; \