aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-01-15 08:08:41 -0500
committerNick Mathewson <nickm@torproject.org>2019-01-15 08:08:41 -0500
commitc281e587bb1b4ac1bdaa97ea68c1ab0c80fe4bab (patch)
tree42690b680a8fff3a9b0711849ac333c7adeb850c /Makefile.am
parentb169c8c14f23394b40305f38ee4ce08add278e27 (diff)
parent30a925fe96ed69284a915c8e80d0f7ef7b556786 (diff)
downloadtor-c281e587bb1b4ac1bdaa97ea68c1ab0c80fe4bab.tar.gz
tor-c281e587bb1b4ac1bdaa97ea68c1ab0c80fe4bab.zip
Merge branch 'ticket28058_squashed'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 84050f8b34..a5086b3035 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,7 +215,16 @@ doxygen:
test: all
$(top_builddir)/src/test/test
-check-local: check-spaces check-changes check-includes
+shellcheck:
+ # Only use shellcheck if it is present
+ if command -v shellcheck; then \
+ find $(top_srcdir)/scripts/ -name "*.sh" -exec shellcheck {} +; \
+ if [ -d "$(top_srcdir)/scripts/test" ]; then \
+ shellcheck $(top_srcdir)/scripts/test/cov-diff $(top_builddir)/scripts/test/coverage; \
+ fi; \
+ fi
+
+check-local: check-spaces check-changes check-includes shellcheck
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \