aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-11-05 08:57:39 -0500
committerNick Mathewson <nickm@torproject.org>2019-11-05 08:57:39 -0500
commitc01f624f4a55dbf97cc39e70700143551d4f571c (patch)
tree01a5aafbba0ecedf57cf775ba9bee3ddcfbbb51d /Makefile.am
parentfa860b6b1770c182986ab998eda8b8e16178e338 (diff)
downloadtor-c01f624f4a55dbf97cc39e70700143551d4f571c.tar.gz
tor-c01f624f4a55dbf97cc39e70700143551d4f571c.zip
Another attempt to fix Doxygen references in out-of-tree builds
This time, we're using cd to run doxygen from inside the source directory, not the build directory at all. This lets us call the source directory ".", which (I hope) both Doxygen 1.8.13 and 1.8.15 will understand. Naturally, this requires a corresponding change in the doxygen configuration so that we are directing the output to the correct place. Fix for 32378.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b2772577f..1234b6d22f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -244,7 +244,8 @@ dist-rpm: dist-gzip
.PHONY: doxygen
doxygen: Doxyfile
- mkdir -p doc/doxygen && doxygen
+ mkdir -p doc/doxygen
+ (cd "$(top_srcdir)" && doxygen "$(abs_top_builddir)/Doxyfile")
test: all
$(top_builddir)/src/test/test