aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-10-23 15:44:17 +1000
committerteor <teor@torproject.org>2019-10-25 16:08:35 +1000
commitba64caee87146a8eda1b2b229236040d46d0f076 (patch)
tree93a2482802130160e97b51f2dc47d6a078e96ade /Makefile.am
parent1094389d8215ce5398a4cd145560bb2686cbf0f5 (diff)
downloadtor-ba64caee87146a8eda1b2b229236040d46d0f076.tar.gz
tor-ba64caee87146a8eda1b2b229236040d46d0f076.zip
Makefile: Add check_cocci_parse.sh as check-cocci
And add it to check-local. Part of 31919.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 32cb21f38c..539541f7fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -188,7 +188,13 @@ EXTRA_DIST+= \
scripts/maint/practracker/testdata/header.h \
scripts/maint/practracker/testdata/not_c_file \
scripts/maint/practracker/test_practracker.sh \
- scripts/maint/practracker/util.py
+ scripts/maint/practracker/util.py \
+ scripts/coccinelle/apply.sh \
+ scripts/coccinelle/check_cocci_parse.sh \
+ scripts/coccinelle/exceptions.txt \
+ scripts/coccinelle/test-operator-cleanup \
+ scripts/coccinelle/tor-coccinelle.h \
+ scripts/coccinelle/try_parse.sh
## This tells etags how to find mockable function definitions.
AM_ETAGSFLAGS=--regex='{c}/MOCK_IMPL([^,]+,\W*\([a-zA-Z0-9_]+\)\W*,/\1/s'
@@ -246,7 +252,7 @@ test: all
shellcheck:
$(top_srcdir)/scripts/maint/checkShellScripts.sh
-check-local: check-spaces check-changes check-includes check-best-practices shellcheck
+check-local: check-spaces check-changes check-includes check-best-practices shellcheck check-cocci
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \
@@ -379,6 +385,9 @@ if USEPYTHON
@$(PYTHON) $(top_srcdir)/scripts/maint/practracker/practracker.py $(top_srcdir) $(TOR_PRACTRACKER_OPTIONS)
endif
+check-cocci:
+ VERBOSE=1 $(top_srcdir)/scripts/coccinelle/check_cocci_parse.sh $(OWNED_TOR_C_FILES)
+
practracker-regen:
$(PYTHON) $(top_srcdir)/scripts/maint/practracker/practracker.py --regen $(top_srcdir)