aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2020-02-13 11:57:36 +1000
committerteor <teor@torproject.org>2020-02-13 13:00:15 +1000
commit9d352028e60fa5b2b239f6ce0803c2b1b0cb5d84 (patch)
treed97060df663a24071a1659a8c9fa799886f8b02d /Makefile.am
parentc33ffe013bd84d6246a2a9e59ccb82a599b89030 (diff)
downloadtor-9d352028e60fa5b2b239f6ce0803c2b1b0cb5d84.tar.gz
tor-9d352028e60fa5b2b239f6ce0803c2b1b0cb5d84.zip
Makefike: Add an IPv6 test to test-network
The IPv6 test only runs if IPv6 is available. Also, explicitly use the bridges+hs-v2 network for the IPv4-only test. This network was chutney's default as of January 2020. Closes 33300.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f93e9f5c8..72ea34380d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -275,6 +275,9 @@ check-local: \
shellcheck \
check-cocci
+# test-network requires a copy of Chutney in $CHUTNEY_PATH.
+# Chutney can be cloned from https://git.torproject.org/chutney.git .
+.PHONY: need-chutney-path
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \
echo '$$CHUTNEY_PATH was not set.'; \
@@ -287,10 +290,14 @@ need-chutney-path:
fi \
fi
-# Note that test-network requires a copy of Chutney in $CHUTNEY_PATH.
-# Chutney can be cloned from https://git.torproject.org/chutney.git .
-test-network: need-chutney-path $(TESTING_TOR_BINARY) src/tools/tor-gencert
- $(top_srcdir)/src/test/test-network.sh $(TEST_NETWORK_FLAGS)
+# Run some basic tests using automake's test-driver
+.PHONY: test-network
+test-network:
+ @$(MAKE) test-network-mkdir
+ @$(MAKE) test-network-clean
+ @$(MAKE) test-network-ipv4-impl ipv4_flavors="$(TEST_CHUTNEY_FLAVOR_QUICK)"
+ @$(MAKE) test-network-ipv6-impl ipv6_flavors="$(TEST_CHUTNEY_FLAVOR_QUICK_IPV6)"
+ @$(MAKE) test-network-results
# Run all available tests using automake's test-driver
.PHONY: test-network-all