aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-08-29 21:56:16 +1000
committerteor <teor@torproject.org>2019-08-29 21:56:16 +1000
commit664d1b436651aca81579a06cde8437ae8f15484f (patch)
tree1baf199c363798dc4896a995ac0f461c5caffaa9 /Makefile.am
parent190386f1c44462fbef568ca9e3c1c997dbebcf12 (diff)
downloadtor-664d1b436651aca81579a06cde8437ae8f15484f.tar.gz
tor-664d1b436651aca81579a06cde8437ae8f15484f.zip
test: Change "make test-stem" so it only runs the stem tests that use tor
This change makes test-stem faster and more reliable. Use "make test-stem-full" to run all of stem's tests. Closes ticket 31554.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b268180c5b..5d18666edc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -275,7 +275,7 @@ need-stem-path:
fi
test-stem: need-stem-path $(TESTING_TOR_BINARY)
- @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --integ --log notice --target RUN_ALL;
+ @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --integ --test control.controller --test control.base_controller --test process --log notice;
test-stem-full: need-stem-path $(TESTING_TOR_BINARY)
@$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --all --log notice --target RUN_ALL,ONLINE -v;