aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-12-04 12:21:53 -0500
committerNick Mathewson <nickm@torproject.org>2019-12-04 12:21:53 -0500
commit64d6914232c5ecba2954e9c7a5f6a6b9b8b5fec6 (patch)
tree000b562f7522575001620d6e51300a9a62ecfea6 /Makefile.am
parentfcb565612801ebcbbc27d47b19644039dfdebed2 (diff)
downloadtor-64d6914232c5ecba2954e9c7a5f6a6b9b8b5fec6.tar.gz
tor-64d6914232c5ecba2954e9c7a5f6a6b9b8b5fec6.zip
Split a few long lists in Makefiles.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 27 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index ba79fd3541..58b791a619 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,12 @@ AM_CPPFLAGS=\
-I$(top_srcdir)/src/ext/trunnel \
-I$(top_srcdir)/src/trunnel
-AM_CFLAGS=@TOR_SYSTEMD_CFLAGS@ @CFLAGS_BUGTRAP@ @TOR_LZMA_CFLAGS@ @TOR_ZSTD_CFLAGS@
+AM_CFLAGS= \
+ @TOR_SYSTEMD_CFLAGS@ \
+ @CFLAGS_BUGTRAP@ \
+ @TOR_LZMA_CFLAGS@ \
+ @TOR_ZSTD_CFLAGS@
+
SHELL=@SHELL@
if COVERAGE_ENABLED
@@ -263,7 +268,14 @@ shellcheck:
check-practracker-unit-test:
$(top_srcdir)/scripts/maint/practracker/test_practracker.sh
-check-local: check-spaces check-changes check-includes check-practracker-unit-test check-best-practices shellcheck check-cocci
+check-local: \
+ check-spaces \
+ check-changes \
+ check-includes \
+ check-practracker-unit-test \
+ check-best-practices \
+ shellcheck \
+ check-cocci
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \
@@ -333,9 +345,19 @@ test-stem: need-stem-path $(TESTING_TOR_BINARY)
test-stem-full: need-stem-path $(TESTING_TOR_BINARY)
@$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --all --log notice --target RUN_ALL,ONLINE -v;
-test-full: need-stem-path need-chutney-path check test-network test-stem
-
-test-full-online: need-stem-path need-chutney-path check test-network test-stem-full
+test-full: \
+ need-stem-path \
+ need-chutney-path \
+ check \
+ test-network \
+ test-stem
+
+test-full-online: \
+ need-stem-path \
+ need-chutney-path \
+ check \
+ test-network \
+ test-stem-full
# We can't delete the gcno files, because they are created when tor is compiled
reset-gcov: