aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-10-16 09:56:31 -0400
committerNick Mathewson <nickm@torproject.org>2019-10-16 09:56:31 -0400
commit593acfabb3a074602aee4f93ef07c7aa22379f7e (patch)
tree245c1706e994adec10529716023dced607bfada6 /Makefile.am
parent033d76b0e0ad255cec10f9ee048d5bb98c03ce7e (diff)
downloadtor-593acfabb3a074602aee4f93ef07c7aa22379f7e.tar.gz
tor-593acfabb3a074602aee4f93ef07c7aa22379f7e.zip
Doxygen: stop producing LaTeX.
Running doxygen with latex gave us all manner of unicode issues, slowed down the "make doxygen" target by a lot, and added several latex dependencies... all to produce a 4000-page reference manual which is probably not what anybody wanted. Closes ticket 32099.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 485324fc79..f0d960efe7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,8 +236,9 @@ dist-rpm: dist-gzip
echo "RPM build finished"; \
#end of dist-rpm
-doxygen:
- doxygen && cd doc/doxygen/latex && make
+.PHONY: doxygen
+doxygen: Doxyfile
+ doxygen
test: all
$(top_builddir)/src/test/test