aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMicah Elizabeth Scott <beth@torproject.org>2023-07-25 19:28:06 -0700
committerMicah Elizabeth Scott <beth@torproject.org>2023-07-26 12:27:15 -0700
commit95bcd17705af8e85df9893025608f2ea4f57bf37 (patch)
tree77d1930bc3860c1e501f9f0f2994eae9cfa0e017 /Cargo.toml
parent1e3b5c94abcc4802f8932c087d2a288c153dc22a (diff)
downloadtor-95bcd17705af8e85df9893025608f2ea4f57bf37.tar.gz
tor-95bcd17705af8e85df9893025608f2ea4f57bf37.zip
Include a basic Rust wrapper for Equi-X and HashX
The idea behind this is that we may want to start exporting more pieces of c-tor as Rust crates so that Arti can perform cross compatibility and comparison testing using Rust tooling. This turns the 'tor' repo into a Cargo workspace, and adds one crate to start with: "tor-c-equix", rooted in src/ext/equix. This actually includes both Equi-X itself and HashX, since there's less overall duplication if we package these together instead of packaging HashX separately. This patch adds a basic safe Rust interface, but doesn't expose any additional internals for testing purposes. No changes to the C code here or the normal Tor build system. Signed-off-by: Micah Elizabeth Scott <beth@torproject.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000000..44f3cfbd58
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,14 @@
+# See doc/HACKING/Rust.md
+#
+# There is no plan to offer a stable Rust API to the C implementation of Tor.
+# This workspace is for wrapper crates that are used internally by Arti for
+# cross-compatibility and comparison testing.
+
+[workspace]
+
+members = [
+ "src/ext/equix",
+]
+
+resolver = "2"
+