summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2004-03-03 13:23:19 +0000
committerPeter Palfrader <peter@palfrader.org>2004-03-03 13:23:19 +0000
commit3e452fed5446f3e744bf7ea321f6b24e01c97578 (patch)
tree98574ac4c284565e9b38b7e9048332781550d13f
parentee3ed492eed23e5fd3d0888a1d9387108060db7c (diff)
downloadtor-debian-version-0.0.1+0.0.2pre24-1.tar.gz
tor-debian-version-0.0.1+0.0.2pre24-1.zip
Wait for tor to die in init stop. Let the user know if it doesn'tdebian-version-0.0.1+0.0.2pre24-1
svn:r1223
-rw-r--r--debian/changelog3
-rw-r--r--debian/tor.init69
2 files changed, 61 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index d886948edc..a53d7871de 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,9 @@ tor (0.0.1+0.0.2pre24-1) unstable; urgency=low
* Add "# ulimit -c unlimited" to tor.default
* Always enable DataDirectory.
* Actually use dpatch now (to modify upstream torrc.in)
+ * Wait for tor to die in init stop. Let the user know if it doesn't.
- -- Peter Palfrader <weasel@debian.org> Wed, 3 Mar 2004 13:48:09 +0100
+ -- Peter Palfrader <weasel@debian.org> Wed, 3 Mar 2004 14:10:25 +0100
tor (0.0.1+0.0.2pre23-1) unstable; urgency=low
diff --git a/debian/tor.init b/debian/tor.init
index 6643cc2647..63f0ac4473 100644
--- a/debian/tor.init
+++ b/debian/tor.init
@@ -1,26 +1,53 @@
#! /bin/sh
+set -e
+
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/tor
NAME=tor
DESC="tor daemon"
TORLOG=/var/log/tor/log
TORPID=/var/run/tor/tor.pid
+DEFAULTSFILE=/etc/default/$NAME
+WAITFORDAEMON=10
ARGS="--pidfile $TORPID --logfile $TORLOG --runasdaemon 1"
test -x $DAEMON || exit 0
# Include tor defaults if available
-if [ -f /etc/default/tor ] ; then
- . /etc/default/tor
+if [ -f $DEFAULTSFILE ] ; then
+ . $DEFAULTSFILE
fi
-set -e
+wait_for_deaddaemon () {
+ pid=$1
+ sleep 1
+ if test -n "$pid"
+ then
+ if kill -0 $pid 2>/dev/null
+ then
+ echo -n "."
+ cnt=0
+ while kill -0 $pid 2>/dev/null
+ do
+ cnt=`expr $cnt + 1`
+ if [ $cnt -gt $WAITFORDAEMON ]
+ then
+ echo " FAILED."
+ return 1
+ fi
+ sleep 1
+ echo -n "."
+ done
+ fi
+ fi
+ return 0
+}
case "$1" in
start)
if [ "$RUN_DAEMON" != "yes" ]; then
- echo "Not starting $DESC (Disabled in /etc/default/tor)."
+ echo "Not starting $DESC (Disabled in $DEFAULTSFILE)."
else
echo -n "Starting $DESC: "
start-stop-daemon --start --quiet --oknodo \
@@ -32,14 +59,36 @@ case "$1" in
;;
stop)
echo -n "Stopping $DESC: "
- start-stop-daemon --stop --quiet --oknodo --pidfile $TORPID \
- --exec $DAEMON
- echo "$NAME."
+ pid=`cat $TORPID 2>/dev/null` || true
+ if test ! -f $TORPID -o -z "$pid"
+ then
+ echo "not running (there is no $TORPID)."
+ elif start-stop-daemon --stop --quiet --pidfile $TORPID --exec $DAEMON
+ then
+ wait_for_deaddaemon $pid
+ echo "$NAME."
+ elif kill -0 $pid 2>/dev/null
+ then
+ echo "FAILED (Is $pid not $NAME? Is $DAEMON a different binary now?)."
+ else
+ echo "FAILED ($DAEMON died: process $pid not running)."
+ fi
;;
reload|force-reload)
- echo "Reloading $DESC configuration."
- start-stop-daemon --stop --signal 1 --oknodo --quiet --pidfile $TORPID \
- --exec $DAEMON
+ echo -n "Reloading $DESC configuration: "
+ pid=`cat $TORPID 2>/dev/null` || true
+ if test ! -f $TORPID -o -z "$pid"
+ then
+ echo "not running (there is no $TORPID)."
+ elif start-stop-daemon --stop --signal 1 --quiet --pidfile $TORPID --exec $DAEMON
+ then
+ echo "$NAME."
+ elif kill -0 $pid 2>/dev/null
+ then
+ echo "FAILED (Is $pid not $NAME? Is $DAEMON a different binary now?)."
+ else
+ echo "FAILED ($DAEMON died: process $pid not running)."
+ fi
;;
restart)
$0 stop