summaryrefslogtreecommitdiff
path: root/misc/qutebrowser.spec
diff options
context:
space:
mode:
authorFlorian Bruhin <me@the-compiler.org>2020-07-06 12:04:01 +0200
committerFlorian Bruhin <me@the-compiler.org>2020-07-06 12:04:01 +0200
commitad645bba524f6cc27ee8122d44fccd6aea040708 (patch)
tree8f82ac01b97ae8bb202e474947330476a743e04a /misc/qutebrowser.spec
parentb1fb55ea6701ed8b748fc30e8b8d99dac6a84f34 (diff)
downloadqutebrowser-ad645bba524f6cc27ee8122d44fccd6aea040708.tar.gz
qutebrowser-ad645bba524f6cc27ee8122d44fccd6aea040708.zip
Add PYINSTALLER_DEBUG
Diffstat (limited to 'misc/qutebrowser.spec')
-rw-r--r--misc/qutebrowser.spec7
1 files changed, 5 insertions, 2 deletions
diff --git a/misc/qutebrowser.spec b/misc/qutebrowser.spec
index 43a18b6b5..06dd628b3 100644
--- a/misc/qutebrowser.spec
+++ b/misc/qutebrowser.spec
@@ -47,6 +47,9 @@ else:
icon = None
+DEBUG = os.environ.get('PYINSTALLER_DEBUG').lower() in ['1', 'true']
+
+
a = Analysis(['../qutebrowser/__main__.py'],
pathex=['misc'],
binaries=None,
@@ -65,10 +68,10 @@ exe = EXE(pyz,
exclude_binaries=True,
name='qutebrowser',
icon=icon,
- debug=False,
+ debug=DEBUG,
strip=False,
upx=False,
- console=False,
+ console=DEBUG,
version='../misc/file_version_info.txt')
coll = COLLECT(exe,
a.binaries,