summaryrefslogtreecommitdiff
path: root/desktop/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/pyproject.toml')
-rw-r--r--desktop/pyproject.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/desktop/pyproject.toml b/desktop/pyproject.toml
new file mode 100644
index 00000000..d1be9c45
--- /dev/null
+++ b/desktop/pyproject.toml
@@ -0,0 +1,42 @@
+[tool.briefcase]
+project_name = "OnionShare"
+bundle = "org.onionshare"
+version = "2.3.dev2"
+url = "https://onionshare.org"
+license = "GPLv3"
+author = 'Micah Lee'
+author_email = "micah@micahflee.com"
+
+[tool.briefcase.app.onionshare]
+formal_name = "OnionShare"
+description = "Securely and anonymously share files, host websites, and chat with friends using the Tor network"
+icon = "src/onionshare/resources/onionshare"
+sources = ['src/onionshare']
+requires = [
+ "./onionshare_cli-2.3.dev2-py3-none-any.whl",
+ "psutil",
+ "pyside2==5.15.1",
+ "qrcode"
+]
+
+[tool.briefcase.app.onionshare.macOS]
+requires = []
+
+[tool.briefcase.app.onionshare.linux]
+requires = []
+system_requires = [
+ "tor",
+ "obfs4proxy",
+ "gcc",
+ "python3-dev",
+]
+
+[tool.briefcase.app.onionshare.windows]
+requires = ["pywin32"]
+
+# Mobile deployments
+[tool.briefcase.app.onionshare.iOS]
+requires = []
+
+[tool.briefcase.app.onionshare.android]
+requires = []