aboutsummaryrefslogtreecommitdiff
path: root/desktop/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/pyproject.toml')
-rw-r--r--desktop/pyproject.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/desktop/pyproject.toml b/desktop/pyproject.toml
new file mode 100644
index 00000000..79ae4a43
--- /dev/null
+++ b/desktop/pyproject.toml
@@ -0,0 +1,51 @@
+[tool.briefcase]
+project_name = "OnionShare"
+bundle = "org.onionshare.OnionShare"
+version = "2.3.dev1"
+url = "https://onionshare.org"
+license = "GPLv3"
+author = 'Micah Lee'
+author_email = "micah@micahflee.com"
+
+[tool.briefcase.app.helloworld]
+formal_name = "OnionShare"
+description = "OnionShare lets you securely and anonymously send and receive files. It works by starting a web server, making it accessible as a Tor onion service, and generating an unguessable web address so others can download files from you, or upload files to you. It does _not_ require setting up a separate server or using a third party file-sharing service."
+icon = "src/helloworld/resources/helloworld"
+sources = ['src/onionshare']
+requires = [
+ "Click",
+ "eventlet",
+ "Flask",
+ "Flask-HTTPAuth",
+ "flask-socketio",
+ "psutil",
+ "pycryptodome",
+ "PyQt5==5.14",
+ "PyQt5-sip",
+ "PySocks",
+ "qrcode",
+ "requests",
+ "stem",
+ "urllib3",
+]
+
+[tool.briefcase.app.helloworld.macOS]
+requires = []
+
+[tool.briefcase.app.helloworld.linux]
+requires = []
+system_requires = []
+
+[tool.briefcase.app.helloworld.windows]
+requires = ["pywin32"]
+
+# Mobile deployments
+[tool.briefcase.app.helloworld.iOS]
+requires = []
+
+[tool.briefcase.app.helloworld.android]
+requires = []
+
+# TODO: Figure out tests with briefcase
+# Test dependencies: pytest, pytest-faulthandler, pytest-qt
+# Also probably https://pypi.org/project/pytest-briefcase/ \ No newline at end of file