aboutsummaryrefslogtreecommitdiff
path: root/desktop/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/pyproject.toml')
-rw-r--r--desktop/pyproject.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/desktop/pyproject.toml b/desktop/pyproject.toml
index b6fe806e..bea97ccc 100644
--- a/desktop/pyproject.toml
+++ b/desktop/pyproject.toml
@@ -6,11 +6,12 @@ authors = ["Micah Lee <micah@micahflee.com>"]
license = "GPLv3+"
[tool.poetry.dependencies]
-python = ">=3.7,<3.11"
+python = ">=3.8,<3.11"
onionshare_cli = {path = "../cli", develop = true}
-PySide2 = "5.15.2.1"
+PySide6 = "6.4.0"
qrcode = "*"
werkzeug = "~2.0.3"
+python-gnupg = "^0.5.0"
[tool.poetry.dev-dependencies]
click = "*"
@@ -19,6 +20,7 @@ pytest = ">=7.2.0"
pytest-faulthandler = "*"
pytest-qt = ">=4.2.0"
cx_freeze = "*"
+importlib-metadata = "*"
[build-system]
requires = ["poetry-core>=1.0.0"]