summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2016-04-10 14:20:18 -0700
committerMicah Lee <micah@micahflee.com>2016-04-10 14:20:18 -0700
commit00d1e293335061419de1ed8ace4cbd8dc16a16f0 (patch)
tree35be4d5a08e5a626549ce83f8a34f2724237f5b7 /setup.py
parent3b638cfd995062d68082ea377171bbe2f3c4415f (diff)
downloadonionshare-00d1e293335061419de1ed8ace4cbd8dc16a16f0.tar.gz
onionshare-00d1e293335061419de1ed8ace4cbd8dc16a16f0.zip
Switch from py2app to PyInstaller
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 0 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index 9694d712..3d59f5f1 100644
--- a/setup.py
+++ b/setup.py
@@ -96,32 +96,6 @@ if system == 'Linux':
]
)
-elif system == 'Darwin':
- setup(
- name='OnionShare',
- version=version,
- description=description,
- long_description=long_description,
- app=['install/osx_scripts/onionshare-gui'],
- data_files=[
- ('images', images),
- ('locale', locale),
- ('html', ['onionshare/index.html', 'onionshare/404.html']),
- ('', ['version'])
- ],
- options={
- 'py2app': {
- 'argv_emulation': True,
- 'iconfile': 'install/onionshare.icns',
- 'extra_scripts': ['install/osx_scripts/onionshare'],
- 'includes': [
- 'PyQt5', 'PyQt5.QtCore', 'PyQt5.QtGui', 'PyQt5.QtWidgets',
- 'jinja2', 'jinja2.ext', 'jinja2.ext.autoescape', 'sip']
- }
- },
- setup_requires=['py2app', 'flask', 'stem'],
- )
-
elif system == 'Windows':
import py2exe
setup(