summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2015-05-15 17:43:01 -0700
committerMicah Lee <micah@micahflee.com>2015-05-15 17:43:01 -0700
commitad553146c78b7826d6916e1858fb4b869e5bc872 (patch)
tree77c4fc40e5095ec91f1e2ac50772cdb9b8c864dc /setup.py
parenta86cda45491bf20c1b78f63d466cad031d95bf6a (diff)
downloadonionshare-ad553146c78b7826d6916e1858fb4b869e5bc872.tar.gz
onionshare-ad553146c78b7826d6916e1858fb4b869e5bc872.zip
adding html files to Resources, loading them from the correct path, and make sure to include jinja2 extension in py2app (#151)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 69ee2e7b..5aebb980 100644
--- a/setup.py
+++ b/setup.py
@@ -101,13 +101,14 @@ elif system == 'Darwin':
app=['install/onionshare-launcher.py'],
data_files=[
('images', images),
- ('locale', locale)
+ ('locale', locale),
+ ('html', ['onionshare/index.html', 'onionshare/404.html'])
],
options={
'py2app': {
'argv_emulation': True,
'iconfile':'install/onionshare.icns',
- 'includes': ['pip', 'PyQt4', 'PyQt4.QtCore', 'PyQt4.QtGui'],
+ 'includes': ['pip', 'PyQt4', 'PyQt4.QtCore', 'PyQt4.QtGui', 'jinja2', 'jinja2.ext', 'jinja2.ext.autoescape'],
'excludes': ['PyQt4.QtDesigner', 'PyQt4.QtNetwork', 'PyQt4.QtOpenGL', 'PyQt4.QtScript', 'PyQt4.QtSql', 'PyQt4.QtTest', 'PyQt4.QtWebKit', 'PyQt4.QtXml', 'PyQt4.phonon']
}
},