summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2016-02-12 15:45:26 -0800
committerMicah Lee <micah@micahflee.com>2016-02-12 15:45:26 -0800
commitdeac54db92bcabacaa50016e8f37ca1a5d10b3a2 (patch)
tree70e339e4273522422b91230d291048c33312fdaf /setup.py
parent62c69c4c0b2b9be0f273303c4326279ff56cd011 (diff)
downloadonionshare-deac54db92bcabacaa50016e8f37ca1a5d10b3a2.tar.gz
onionshare-deac54db92bcabacaa50016e8f37ca1a5d10b3a2.zip
Made sure switch to python3 and Qt5 works in OSX (#261). Updated OSX instructions in BUILD.md.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 4 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index ab1d990c..9ad89b47 100644
--- a/setup.py
+++ b/setup.py
@@ -106,7 +106,8 @@ elif system == 'Darwin':
data_files=[
('images', images),
('locale', locale),
- ('html', ['onionshare/index.html', 'onionshare/404.html'])
+ ('html', ['onionshare/index.html', 'onionshare/404.html']),
+ ('', ['version'])
],
options={
'py2app': {
@@ -114,17 +115,8 @@ elif system == 'Darwin':
'iconfile': 'install/onionshare.icns',
'extra_scripts': ['install/osx_scripts/onionshare'],
'includes': [
- 'PyQt4', 'PyQt4.QtCore', 'PyQt4.QtGui',
- 'jinja2', 'jinja2.ext', 'jinja2.ext.autoescape'],
- 'excludes': [
- 'PyQt4.QtDesigner', 'PyQt4.QtNetwork',
- 'PyQt4.QtOpenGL', 'PyQt4.QtScript',
- 'PyQt4.QtSql', 'PyQt4.QtTest',
- 'PyQt4.QtWebKit', 'PyQt4.QtXml',
- 'PyQt4.phonon', 'PyQt4.QtDeclarative',
- 'PyQt4.QtHelp', 'PyQt4.QtMultimedia',
- 'PyQt4.QtScript', 'PyQt4.QtScriptTools',
- 'PyQt4.QtSvg', 'PyQt4.QtXmlPatterns']
+ 'PyQt5', 'PyQt5.QtCore', 'PyQt5.QtGui', 'PyQt5.QtWidgets',
+ 'jinja2', 'jinja2.ext', 'jinja2.ext.autoescape', 'sip']
}
},
setup_requires=['py2app', 'flask', 'stem'],