summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2017-02-21 16:59:14 -0800
committerMicah Lee <micah@micahflee.com>2017-02-21 16:59:14 -0800
commit248f59cbd17f2599abb363270574ebd9f4b3cc35 (patch)
tree88c3f9fdc7e33363ce89795f307b9ab180cdcec4 /setup.py
parent535150194390e08ae1b31ef9ab2bc04a7aabe44d (diff)
downloadonionshare-248f59cbd17f2599abb363270574ebd9f4b3cc35.tar.gz
onionshare-248f59cbd17f2599abb363270574ebd9f4b3cc35.zip
Renamed 'resources' to 'share', and updated location of 'share' files in OSX/Win binaries
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 87ce1889..dcbe42fb 100644
--- a/setup.py
+++ b/setup.py
@@ -29,7 +29,7 @@ def file_list(path):
files.append(os.path.join(path, filename))
return files
-version = open('resources/version.txt').read().strip()
+version = open('share/version.txt').read().strip()
description = (
"""OnionShare lets you securely and anonymously share a file of any size with someone. """
"""It works by starting a web server, making it accessible as a Tor hidden service, """
@@ -58,10 +58,10 @@ setup(
(os.path.join(sys.prefix, 'share/applications'), ['install/onionshare.desktop']),
(os.path.join(sys.prefix, 'share/appdata'), ['install/onionshare.appdata.xml']),
(os.path.join(sys.prefix, 'share/pixmaps'), ['install/onionshare80.xpm']),
- (os.path.join(sys.prefix, 'share/onionshare'), file_list('resources')),
- (os.path.join(sys.prefix, 'share/onionshare/images'), file_list('resources/images')),
- (os.path.join(sys.prefix, 'share/onionshare/locale'), file_list('resources/locale')),
- (os.path.join(sys.prefix, 'share/onionshare/html'), file_list('resources/html')),
+ (os.path.join(sys.prefix, 'share/onionshare'), file_list('share')),
+ (os.path.join(sys.prefix, 'share/onionshare/images'), file_list('share/images')),
+ (os.path.join(sys.prefix, 'share/onionshare/locale'), file_list('share/locale')),
+ (os.path.join(sys.prefix, 'share/onionshare/html'), file_list('share/html')),
('/usr/share/nautilus-python/extensions/', ['install/scripts/onionshare-nautilus.py'])
]
)