summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2016-02-12 14:34:19 -0800
committerMicah Lee <micah@micahflee.com>2016-02-12 14:34:19 -0800
commit170811f450b801c03111b1a6ae59ed9808d1bead (patch)
treecddee3ab9af40eb640156f9ae1f3ad4208b00df0 /setup.py
parentb2bda8294ac3e0af76cacdf3a3c02ae5a3740e0c (diff)
downloadonionshare-170811f450b801c03111b1a6ae59ed9808d1bead.tar.gz
onionshare-170811f450b801c03111b1a6ae59ed9808d1bead.zip
Porting onionshare from python2 to python3 (#261). This commit only ports the CLI version, not the GUI. Has not been tested in Fedora, Windows, or OSX. Removed hack to make unicode filenames work because hack does not work in python3. Replaced constant_time_compare function with a new one that works in python3. Tweaked hidden service checking code because urllib is different in python3.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 21ef0906..ecc1f1aa 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
"""
OnionShare | https://onionshare.org/
@@ -83,9 +83,11 @@ if system == 'Linux':
url='https://github.com/micahflee/onionshare',
license="GPL v3",
keywords='onion, share, onionshare, tor, anonymous, web server',
- packages=['onionshare', 'onionshare_gui'],
+ #packages=['onionshare', 'onionshare_gui'],
+ packages=['onionshare'],
include_package_data=True,
- scripts=['install/linux_scripts/onionshare', 'install/linux_scripts/onionshare-gui'],
+ #scripts=['install/linux_scripts/onionshare', 'install/linux_scripts/onionshare-gui'],
+ scripts=['install/linux_scripts/onionshare'],
data_files=[
(os.path.join(sys.prefix, 'share/applications'), ['install/onionshare.desktop']),
(os.path.join(sys.prefix, 'share/appdata'), ['install/onionshare.appdata.xml']),