summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2016-04-12 15:14:02 -0700
committerMicah Lee <micah@micahflee.com>2016-04-12 15:14:02 -0700
commite81f809882b38c2b0890a71ae6e7e00eab7f0687 (patch)
tree54fa2914e996516d65d25f13b63475f30ce75a36 /setup.py
parent7c18d77fb20ea8f852a922fe169bed70f03c713a (diff)
downloadonionshare-e81f809882b38c2b0890a71ae6e7e00eab7f0687.tar.gz
onionshare-e81f809882b38c2b0890a71ae6e7e00eab7f0687.zip
Move all resources (locale, images, html, version.txt) into central resources dir, and clean up logic to find absolute paths to resources
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py48
1 files changed, 27 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 0854a80f..48e5469a 100644
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,7 @@ def file_list(path):
files.append(os.path.join(path, filename))
return files
-version = open('version.txt').read().strip()
+version = open('resources/version.txt').read().strip()
description = (
"""OnionShare lets you securely and anonymously share a file of any size with someone. """
@@ -48,27 +48,32 @@ long_description = description + " " + (
)
images = [
- 'images/logo.png',
- 'images/drop_files.png',
- 'images/server_stopped.png',
- 'images/server_started.png',
- 'images/server_working.png'
+ 'resources/images/logo.png',
+ 'resources/images/drop_files.png',
+ 'resources/images/server_stopped.png',
+ 'resources/images/server_started.png',
+ 'resources/images/server_working.png'
]
locale = [
- 'locale/cs.json',
- 'locale/de.json',
- 'locale/en.json',
- 'locale/eo.json',
- 'locale/es.json',
- 'locale/fi.json',
- 'locale/fr.json',
- 'locale/it.json',
- 'locale/nl.json',
- 'locale/no.json',
- 'locale/pt.json',
- 'locale/ru.json',
- 'locale/tr.json'
+ 'resources/locale/cs.json',
+ 'resources/locale/de.json',
+ 'resources/locale/en.json',
+ 'resources/locale/eo.json',
+ 'resources/locale/es.json',
+ 'resources/locale/fi.json',
+ 'resources/locale/fr.json',
+ 'resources/locale/it.json',
+ 'resources/locale/nl.json',
+ 'resources/locale/no.json',
+ 'resources/locale/pt.json',
+ 'resources/locale/ru.json',
+ 'resources/locale/tr.json'
+]
+
+html = [
+ 'resources/html/index.html',
+ 'resources/html/404.html',
]
setup(
@@ -88,8 +93,9 @@ setup(
(os.path.join(sys.prefix, 'share/applications'), ['install/onionshare.desktop']),
(os.path.join(sys.prefix, 'share/appdata'), ['install/onionshare.appdata.xml']),
(os.path.join(sys.prefix, 'share/pixmaps'), ['install/onionshare80.xpm']),
- (os.path.join(sys.prefix, 'share/onionshare'), ['version.txt']),
+ (os.path.join(sys.prefix, 'share/onionshare'), ['resources/version.txt']),
(os.path.join(sys.prefix, 'share/onionshare/images'), images),
- (os.path.join(sys.prefix, 'share/onionshare/locale'), locale)
+ (os.path.join(sys.prefix, 'share/onionshare/locale'), locale),
+ (os.path.join(sys.prefix, 'share/onionshare/html'), html)
]
)