summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorattila <attila@haqistan.net>2018-02-05 18:06:37 -0500
committerattila <attila@haqistan.net>2018-02-05 18:06:37 -0500
commitae494c8e331cc2c945e66c27cc53344de52e549a (patch)
treec5837688f41c7b06bf461f6f089e35ec28ec8373 /setup.py
parent29ad669e543661b3ce6ec5ec60a8213b73486142 (diff)
downloadonionshare-ae494c8e331cc2c945e66c27cc53344de52e549a.tar.gz
onionshare-ae494c8e331cc2c945e66c27cc53344de52e549a.zip
Second attempt at patches for an OpenBSD port, this time based off of 1.2
and after feedback from the upstream and other contributors at https://github.com/micahflee/onionshare/pull/489
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 12 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index dcbe42fb..23e1ea17 100644
--- a/setup.py
+++ b/setup.py
@@ -45,6 +45,17 @@ author_email = 'micah@micahflee.com'
url = 'https://github.com/micahflee/onionshare'
license = 'GPL v3'
keywords = 'onion, share, onionshare, tor, anonymous, web server'
+data_files=[
+ (os.path.join(sys.prefix, 'share/applications'), ['install/onionshare.desktop']),
+ (os.path.join(sys.prefix, 'share/appdata'), ['install/onionshare.appdata.xml']),
+ (os.path.join(sys.prefix, 'share/pixmaps'), ['install/onionshare80.xpm']),
+ (os.path.join(sys.prefix, 'share/onionshare'), file_list('share')),
+ (os.path.join(sys.prefix, 'share/onionshare/images'), file_list('share/images')),
+ (os.path.join(sys.prefix, 'share/onionshare/locale'), file_list('share/locale')),
+ (os.path.join(sys.prefix, 'share/onionshare/html'), file_list('share/html')),
+ ]
+if platform.system() != 'OpenBSD':
+ data_files.append(('/usr/share/nautilus-python/extensions/', ['install/scripts/onionshare-nautilus.py']))
setup(
name='onionshare', version=version,
@@ -54,14 +65,5 @@ setup(
packages=['onionshare', 'onionshare_gui'],
include_package_data=True,
scripts=['install/scripts/onionshare', 'install/scripts/onionshare-gui'],
- data_files=[
- (os.path.join(sys.prefix, 'share/applications'), ['install/onionshare.desktop']),
- (os.path.join(sys.prefix, 'share/appdata'), ['install/onionshare.appdata.xml']),
- (os.path.join(sys.prefix, 'share/pixmaps'), ['install/onionshare80.xpm']),
- (os.path.join(sys.prefix, 'share/onionshare'), file_list('share')),
- (os.path.join(sys.prefix, 'share/onionshare/images'), file_list('share/images')),
- (os.path.join(sys.prefix, 'share/onionshare/locale'), file_list('share/locale')),
- (os.path.join(sys.prefix, 'share/onionshare/html'), file_list('share/html')),
- ('/usr/share/nautilus-python/extensions/', ['install/scripts/onionshare-nautilus.py'])
- ]
+ data_files=data_files
)